Excel Workshop, Part 2
Step by step tutorial
For Thursday, February 22nd, 2018
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[bookmark: _Toc507076222]Objectives
1. To reorient everyone to the excel layout and reaffirm key terms
2. To demonstrate intermediate tools and skills 
3. To practice skills learned in the previous workshop
4. To learn the wonders of the Autofill handle for data entry
5. To learn to fix rows and perform more sorting functions
6. To practice with formulas 
7. Learn basic skills with charts and figure manipulation
8. Introduce pivot tables and their functions and purposes
[bookmark: _Toc507076223]Open Excel
Start with blank workbook but remind everyone to explore templates based on their needs.
[bookmark: _Toc507076224]Exercise
1. In table columns, enter 5 of your favorite movies: Title, Genre, Year of Release, Ranking on scale 1-10
2. Create a table header and merge and center it
3. Adjust all columns so that values are completely visible
4. Copy your table and paste it into a new worksheet
5. Sort data by title
6. Perform Conditional Formatting by rank using a color scheme of your choosing
7. Calculate average movie rating
8. Make your title a different font and background color
9. Format as a table
[bookmark: _Toc507076225]Quick Refresher
[bookmark: _Toc507076226]Layout
Go over the layout once more: tabs with ribbons and then groups within each ribbon. Each group has a launch button for more options.
[bookmark: _Toc507076227]Spreadsheet
	Columns (letters) and Rows (numbers)
	Cells-each one has a name based on intersection between column and row. 
	Each row contains a record
Sheets are at the bottom and they comprise the Workbook
[bookmark: _Toc507076228]Commands
· Shift enter moves up and enter/return moves down
· Tab to the right, shift tab to the left
· Up/Down/Left/Right arrows
[bookmark: _Toc507076229]Labeling
· When you click on the cell, anything you type replaces what was there because you are on a cell. 
· Difference between being in a cell and being on a cell
[bookmark: _Toc507076230]Autofill Handle
· Learned about the autofill handle: a basic command of excel whereby a value in one cell can be duplicated in others next to it. 
[bookmark: _Toc507076231]Deleting Cells
· We learned to delete cells: right click and hit delete
· Excel will ask you if you want to shift your cells up, down, left or right. When you do this and you have other data present on your spreadsheet, be aware that it will also shift those cells as well so think carefully about which way you want your cells to shift
[bookmark: _Toc507076232]Merge and Center
· Select all the cells in the corresponding rows and merge and center so that it’s one big cell
[bookmark: _Toc507076233]Adjusting Margins
· Double click between columns to perfectly fit the widest cell. OR click and drag
[bookmark: _Toc507076234]Formatting
Copy format function can be found in the upper left corner of excel in the clipboard group that	looks like a paintbrush. It will copy the format of a cell so that you can have the same	format in other cells. It doesn’t change the content it just changes the cell format.
[bookmark: _Toc507076235]Conditional Formatting
· Highlight a column and go up to conditional formatting and it will assign a color to a value present in your data set as an easy way to organize and visualize your information
[bookmark: _Toc507076236]Formula
· Start with = then tell excel what you want it to do. Don’t forget the Formulas Tab for more ideas and functions in the Formula Library!
[bookmark: _Toc507076237]Sort and Filter 
Highlight all the values in the fields and hit sort and filter in the upper right corner.
· Select Custom Sort for more autonomy
· Select all the ages by dragging mouse from the first number to the last number OR you can just perform the function without selecting the data and it will automatically select the data above just be careful with your result that it took the correct data
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[bookmark: _Toc507076239]Autofill Handle 
· The autofill handle allows you to easily copy formulas, numbers or texts into other cells by clicking on the bottom right corner of the cell you want replicated and dragging it to a cell close by. 
· You can also use it to fill in obvious chronological data such as dates, times, months, currency etc. Excel will automatically recognize what you’re trying to do and will save you the trouble of entering all the values yourself. 
· Example: in excel select a cell and type in January
· Hover mouse over the bottom right corner of the cell until the little black X appears. Click and drag down to see the progression of months.
· Do the same with the date and next with a series of numbers (32, 34, 36). Highlight all the numbers and click the bottom right X of the group and drag down. Notice that Excel automatically recognizes the pattern you’re trying to follow and fills it in!
[bookmark: _Toc507076240]Create some turtle data!
Column A will be Male/Female. 
· Cell A2 type M and cell A3 type F. 
· Highlight both cells then click the bottom right corner and drag down to row 25
Column B will be Body Length in cm
· Cell B2 type 12 and cell B3 type 14
· Highlight both cells then click the bottom right corner and drag down to row 25
Column C will be Turtle Color
· Cell C2 type Green, C3 type Blue, C4 type Purple
· Highlight all 3 cells then click the bottom right corner and drag down to row 25
Column D will be Turtle Shell Width in cm
· Cell D2 type 5, D3 type 10
· Highlight both cells then click the bottom right corner and drag down to row 25
Column E will be Months Recorded
· Cell E2 type January
· Click the bottom right corner of January and drag down to row 25
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Now we are going to fix the header row so that even if we are scrolling down or up, we can always see the headers and we don’t have to keep going back to the top of the page to make sure we’re on the right data points.
· Click on the row below the row you want to fix, in this case it is Row 2
· Make sure it is highlighted then go to the View tab. Under the View ribbon is the Window group. 
· Click on the function Freeze Panes and select the option to freeze the top row only (2nd option)
· The row is now fixed and you can scroll up and down the data set to see the information and the headers simultaneously!
[bookmark: _Toc507076242]Sort and Filter: Extreme!
Next we are going to perform the sort and filter function by providing more short cuts for this data set.
· Highlight the first Row and go to the Data Tab. Under the Data ribbon is the Sort & Filter group. 
· Click on the function Filter which will now place drop down arrows next to each header.
· You can now pick a header and sort your data according to the criteria you specify in each column and don’t worry, the rest of your data will follow the commands you place on a single column.
[bookmark: _Toc507076243]Practice Time with Formulas (15 min)
Please perform the following tasks on your own based on the content we learned last time:
· Find the Sum total of Turtle Body Lengths and Shell Width 
· Find the Average of Turtle Body Lengths and Shell Width
· Find the Minimum of Turtle Body Lengths and Shell Width
· Find the Maximum of Turtle Body Lengths and Shell Width
Using the Formulas tab, can you calculate the Standard Deviation for either Body Lengths or Shell Width?
· Click on a cell you wish the standard deviation to appear
· Go to the Formulas tab and under the Function Library group click on the Insert Function option
· In the Insert Function dialogue box type in standard deviation
· Select STDEV and hit OK then highlight the values you want to calculate and hit Enter
· The Standard deviation will appear in the cell you originally clicked within!
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Now we will try to look at the data using charts. We don’t want to provide Excel with too many variables for charts which typically can only handle two to three variables at a time, depending on what you’re trying to do.
Experiment!
· Highlight columns with Shell Width, Body Length and Male/Female
· Go to the Insert tab and under the Charts group, select Recommended Charts
· Excel will give you a list of ideas that it thinks you want based on the data you provided
· Notice that Excel does not automatically average the data, the points or the values are all summary data, if you want averages like say the average Female Shell Width to compare to the Average Male Shell Width, you would need to calculate that first and then highlight the averages to produce a chart. In statistical analysis software such as JMP and R, the program will perform those functions for you, but that is for another session!
· For the purposes of this data, we will select the chart that demonstrates the time-lapse of the data collection or we can look at the sum total of the shell widths and body lengths but that does not help us understand the relationships very well.
· You can experiment with clicking on the small green cross in the upper right hand corner of the chart to activate chart axis and titles.
· Click on the axis values and scroll to the bottom of the selection menu and select the value you want to place on the data such as percentages, dollars etc.
[bookmark: _Toc507076245]Pivot Tables (And the Difference Between PTs and Crosstabs)
This data really requires a cross tabulation or counts of the differences between the variables so that they can be compared to one another. Crosstabs are useful because they allow information to be recorded on both the column and row headers; however, you will not be able to manipulate cross tabs after you have created them. This is why Pivot Tables are so beneficial and we can now try to manipulate the data using the Pivot Table Functions in Excel.
· First select all the data you’ve entered then under the Insert Tab go to the Charts group and select Pivot Chart
· When the dialog box opens up, make sure it has all the data you want entered from the first to the last cell and that the New Worksheet option is checked as this is where the pivot table will go.
· You are now looking at a blank pivot table worksheet. Don’t be afraid that you can’t see your data, you haven’t lost it, the pivot table has just been opened in a new Sheet which you can see at the bottom. 

[bookmark: _GoBack]MES staff are offering an Excel Workshop the second week of Spring quarter, Friday April 13th from 5:00pm - 7:00pm in CAL West. This workshop will act as a refresher for RDQM and third year track students and assist thesis students with data sorting and manipulation in Excel. The primary purpose is to answer any questions you may have and to learn with each other as we explore the wonderful world of Excel! 

If you're not sure if you should attend this workshop, please attempt the below exercise MES staff developed based on content from Excel workshop Part 1 in Winter quarter:

Excel Exercise (Like running for your brain):
1.       In table columns, enter 5 of your favorite movies: Title, Genre, Year of Release, and Rating so each Movie is ranked on a scale 1-10
2.       Create a table header then merge and center it
3.       Adjust all columns so that values are completely visible
4.       Copy your table and paste it into a new worksheet
5.       Sort data alphabetically by title
6.       Perform Conditional Formatting by rank using a color scheme of your choosing
7.       Calculate the sum, minimum, maximum and average movie rating
8.       Use Insert Function to find the formula to calculate the standard deviation of your movie ratings
9.       Make your title a different font and background color
10.      Format as a table

If the above exercise is challenging for you (or if it caused a stress-induced eye twitch/heart palpitation), please consider attending this workshop to refresh your memory and get to know your friend Excel. We know that many of you work during the day, which is why we wanted to inquire as to how many of you could, or would, show up to this workshop on Friday the 13th, despite how ominous it sounds. Note that if you cannot make it to the workshop by 5:00pm, you are still welcome to show up later that evening to ask questions, learn from your peers and pick-up some nifty workshop materials we will have on hand. 

Please RSVP by Tuesday, April 10th with your decision.

As always, if you have any questions email Andrea Martin at martina@evergreen.edu or Averi Azar at azara@evergreen.edu.
